
<!DOCTYPE html>
<!--==================================================
==================START: HEADER====================-->
<html lang="en">
	<head>
		
		<!--
macro: mainmeta (MCD 201610140350)
current date: 20201009015742
template: 
currentrequest: /apps/pbcs.dll/article?avis=TX&date=20201009&category=NEWS&lopenr=201009005&Ref=AR
currentrequestunmodified: /news/20201009/howe-isd-board-candidates-share-thoughts-on-past-future-of-district
@templatetype: /apps/pbcs.dll/article?avis=TX&date=20201009&category=NEWS&lopenr=201009005&Ref=AR
@pagetype: article
app version: 2.0.480
-->
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta property="og:site_name" content="Stephenville Empire-Tribune" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> 
<meta name="msvalidate.01" content="7E15F9269E2CE66F2A488ABB04B5015E" />

		<title> Howe ISD board candidates share thoughts on past, future of district - News - Stephenville Empire-Tribune - Stephenville, TX</title>
<!-- Meta Tags - Global Article6 guid: 64A60A39-0A61-4B56-AC8A-2A9983AF016F-->
<meta name="description" content="Among many races on the ballot this fall, voters in the Howe Independent School District will get to choose two seats on the board of trustees.Incumbent Clint Catching will face challengers Jeff Dailey, Charles Haley and Lisa Tibbets. The top two vote-getters in the election will be placed on the board for a three-year term.Early voting for the Howe ISD race begins Oct. 13 and continues through Oct. 30. Election day is Nov. 3. Grayson County voters can cast their ballots at any polling location " />
<meta property="bt:pubDate" content="20201009T00:01:00Z">
<meta property="bt:modDate" content="20201009T00:00:00Z">
<meta property="bt:author" content="Joshua Baethge, For the Van Alstyne Leader">
<meta name="twitter:title" content="Howe ISD board candidates share thoughts on past, future of district">
<meta name="twitter:description" content="Among many races on the ballot this fall, voters in the Howe Independent School District will get to choose two seats on the board of trustees.Incumbent Clint Catching will face challengers Jeff Dailey, Charles Haley and Lisa Tibbets. The top two vote-getters in the election will be placed on the board for a three-year term.Early voting for the Howe ISD race begins Oct. 13 and continues through Oct. 30. Election day is Nov. 3. Grayson County voters can cast their ballots at any polling location ">
<meta property="og:title" content="Howe ISD board candidates share thoughts on past, future of district"/>
<meta property="og:description" content="Among many races on the ballot this fall, voters in the Howe Independent School District will get to choose two seats on the board of trustees.Incumbent" />
<meta name="author" content="Joshua Baethge, For the Van Alstyne Leader">
	<meta name="twitter:card" content="summary">
	<meta name="twitter:image" content="https://www.yourstephenvilletx.com/storyimage/TX/20201009/NEWS/201009005/AR/0/AR-201009005.jpg&MaxW=1200&MaxH=630">
	<meta property="og:image" content="https://www.yourstephenvilletx.com/storyimage/TX/20201009/NEWS/201009005/AR/0/AR-201009005.jpg">
	<meta property="og:image:width" content="190">
	<meta property="og:image:height" content="190">
	<meta property="vf:unique_id" content="siteTX-pub3632-64A60A39-0A61-4B56-AC8A-2A9983AF016F">
	<link rel="canonical" href="https://www.yourstephenvilletx.com/news/20201009/howe-isd-board-candidates-share-thoughts-on-past-future-of-district"/>
<link rel="amphtml" href="https://www.yourstephenvilletx.com/news/20201009/howe-isd-board-candidates-share-thoughts-on-past-future-of-district?template=ampart">
<script type="application/ld+json">
  {
    "@context": "http://schema.org",
    "@type": "NewsArticle",
    "mainEntityOfPage": {
		"@type": "WebPage",
		"@id": "https://www.yourstephenvilletx.com/news/20201009/howe-isd-board-candidates-share-thoughts-on-past-future-of-district"
	},
    "headline": "Howe ISD board candidates share thoughts on past, future of district",
    "image": {
       "@type": "ImageObject",
       	"url":"https://www.yourstephenvilletx.com/storyimage/TX/20201009/NEWS/201009005/AR/0/AR-201009005.jpg",
       	"height": 190,
       	"width": 190
    },
    "url": "https://www.yourstephenvilletx.com/article/20201009/NEWS/201009005",
    "thumbnailUrl": "https://www.yourstephenvilletx.com/apps/pbcsi.dll/bilde?Site=TX&Date=20201009&Category=NEWS&ArtNo=201009005&Ref=AR",
    "dateCreated": "20201009T06:01:00Z",
    "datePublished": "20201009T06:01:00Z",
    "dateModified": "20201009T06:00:00Z",
    "author": [{"@type":"Person","name":"Joshua Baethge, For the Van Alstyne Leader"}],
    "creator": "Joshua Baethge, For the Van Alstyne Leader",
    "publisher": {
       "@type": "Organization",
       "name": "Stephenville Empire-Tribune",
       "logo": {
         "@type": "ImageObject",
         "url": "https://www.yourstephenvilletx.com/Global/images/head/nameplate/yourstephenvilletx_logo.png"
       }
    },
    "articleSection": "News",
    "keywords": ["News","Carousel / Featured","Redesign: Below Featured","TX_vanalstyneleader.com"],
    "isAccessibleForFree": "false",
	"hasPart":
	{
		"@type": "WebPageElement",
		"isAccessibleForFree": "False",
		"cssSelector" : ".paywall-is-accessible-for-free"
	},
	"isPartOf": {
    "@type": ["CreativeWork", "Product"],
    "name" : "Stephenville Empire-Tribune",
    "productID": "yourstephenvilletx.com:standard"
	}
  }
</script>
<meta property="fb:app_id" content="1650681501873672"/>
<meta name="twitter:site" content="@empiretribune">
<meta property="og:type" content="article"/>
<meta property="article:opinion" content="false"/>

		<script type="text/javascript">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</script>
				        <link rel="stylesheet" type="text/css" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700|Roboto+Condensed:400,400i,700,700i|Crimson+Text:400,400i,700,700i|Rubik:400,500,700,900" crossorigin="anonymous" />
        <link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" type="text/css" crossorigin="anonymous" />
        <link rel="stylesheet" href="//cdn.gatehousemedia.com/assets/css/2.0.480/default.min.css" type="text/css" crossorigin="anonymous" />
		<style type="text/css">
	/*legacy-header*/
	.legacy-header #baseLeaderboard {
		margin-top:25px;
	}
	#header-content div#slidingBillboard.ad.text-center {
		padding: 0;
		margin: 0;
	}
	#article > div > section.article-v2-left > div.ad-container { clear: both; }
	@media only screen and (max-width: 768px) {
		#buckets > div.article-extra > h4.chatter-title {
		    font-size: 2em;
		}
	}
	section.article-v2-right > div.article-body.p402_premium > div.vendor-logo.byline-item > img{
		max-width: 150px;
	}
	#apoc-breaking-wrapper{position: relative;z-index:100;}
    /*==== ARTICLE ======*/
    	.ad-300x150{
	    	width: 300px;
	    	max-height: 150px;
    	}
    	.adInject{
	    	clear:both;
    	}
    	.articleInjectAd{
	    	display: none;
    	}
    	.native-injected{
	    	height: 0px;
    	}
    	/*story strip article ad*/
    	/* cssUpdates branch*/
    	div.gh-slider-storyStrip > div.adInject > div > iframe {
			max-height:90px;
		}
    	/* cssUpdates branch*/
    	.gh-slider-caption h3:not(.is-truncated):not([style="word-wrap: break-word;"]){
			-webkit-line-clamp: 4;
		    text-overflow: ellipsis;
    	}
    	/* Buzz widget */
    	#gh-slider-buzz > div > div > figure > a > div.image.unveil-loaded{
			min-height: 112px;
			box-shadow: 0px 0px 5px 0px rgba(50, 50, 50, 0.75);
			border-radius: 2px;
    	}
    	#gh-slider-buzz{
    		font-family: "Roboto Condensed","Helvetica Neue","Helvetica","Roboto","Arial",sans-serif;
    	}
    	#gh-slider-buzz h3 > span{
    		font-weight: bold;
			font-size: 14.4px;
			color:rgb(68, 68, 68);
			text-decoration-color:rgb(68, 68, 68);
			line-height: 16px;
    	}
    	#gh-slider-buzz h3 > span:hover{
			text-decoration: underline;
    	}
    	#gh-slider-buzz .dateline{
			font-size: 10px;
			color:rgb(153, 153, 153);
			text-decoration-color:rgb(153, 153, 153);
    	}
    	#gh-slider-buzz .gh-slider-caption h3{
	    	max-height: 500px;
    	}
    	#gh-slider-buzz div.nophoto > a > h3{
	    	margin-bottom: 5px;
    	}
    	#gh-slider-buzz div.nophoto{
	    	padding:0px;
    	}
    	#gh-slider-buzz span.summary{
	    	font-size: 11px;
		    max-height: 140px;
		    display: block;
		    line-height: 14px;
		    overflow: hidden;
    	}
    	#gh-slider-buzz .slick-slider,#buzz-widget-mobile .section-ribbon,#buzz-widget .section-ribbon{
	    	margin-bottom: 0px;
    	}
    	.article-meta-day,a:visited  {
			font-family: "Roboto Condensed","Helvetica Neue","Helvetica","Roboto","Arial",sans-serif;
			font-size: 18.662px;
			font-weight: bold;
			color: #698096;
			display: block;
			font-kerning: normal;
			text-rendering: optimizeLegibility;
			margin-bottom: 10px;
			text-decoration: none;
		}
		#flipp-promo {
		    max-width: 300px;
		    margin: 0 auto;
		    max-height: 250px;
		 }
    	/* Viafoura email & password fields in registration/signup screens */
	 	.viafoura .vf-forgot-pw-link, .viafoura .vf-account-form {
	 		display: none;
	 	}
    	/*  TERMS OF SERVICE LINK - under viafoura comments submit button */
    	.vf-terms-of-service { margin-left: 12px;}
		/* TOUT MID ARTICLE PLAYER */
		.tout-mid-article { display:block; margin-right:2.35%; width:100%; }
	/* MOBILE article story stack */
    .gh-article-storyStack {
        background-color: #f3f3f3;
        display: inline-block;
        width: 100%;
        height: 150vw;
    }
    .gh-stacked {
        display: inline-block;
        padding: 2vw 2vw 4vw 2vw;
        margin: 0 0 3vw 0;
        height: 25vw;
        width: 100%;
    }
    .gh-stacked figure {
        width: 20vw;
        height: 20vw;
        display: inline-block;
        float: left;
        /* margin: 0 3vw 0 0; */
    }
    .gh-stacked h3 {
        width: calc(100% - 4.8em - 1.618em);
	    font-size: 1.25em;
	    line-height: 1.3em;
	    float: left;
	    display: inline;
    }
    .gh-article-storyStack .slick-slide .image{min-height:80px !important;}
    .gh-article-storyStack .slick-slide a{display:block;height:100%;width:100%;border-bottom: 1px solid #454545;margin-bottom:5px;}
</style>
		<style>
@media screen and (min-width: 768px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:lightskyblue;}
}
@media screen and (max-width: 767px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:#039be5;}
}
</style>
				<script type="text/javascript">
			window.supportsLocalStorage = false;
			try {
				window.supportsLocalStorage = !!window.localStorage
				    && typeof localStorage.getItem === 'function'
				    && typeof localStorage.setItem === 'function'
				    && typeof localStorage.removeItem === 'function';
			} catch(e) {
				console.error('localStorage error', e);
			}
			if(window.supportsLocalStorage === false) {
				console.warn('localStorage is not supported on this browser.');
			}
		</script>
		<script src="https://cdnjs.cloudflare.com/ajax/libs/jquery/2.1.4/jquery.min.js?20160411-3" crossorigin="anonymous"></script>
		<!-- Google Tag Manager -->
<script>
  //PAGE DATA
  __gh__coreData.pageData.type2 = "Article";
  __gh__coreData.pageData.error = __gh__coreData.pageData.type2 == "404" ? "404" : undefined;
  //USER
  __gh__coreData.user = {id:undefined,accessLevel:undefined};
  // Get clientside pieces from LocalStorage object
  if (window.supportsLocalStorage === true && typeof localStorage['_vxData'] != "undefined"){
    var _vxDataObj = JSON.parse(localStorage['_vxData']);
    __gh__coreData.user				= _vxDataObj;
  }
  //define main dataLayer for object for GTM
  window.dataLayer 	= window.dataLayer || [];
  dataLayer.push(__gh__coreData);
var __gh__gtm = {
	id:'GTM-WF5MZJ9'
};
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer',__gh__gtm.id);
</script>
<!-- End Google Tag Manager -->
		<script async='async' src='//cdn.adsafeprotected.com/iasPET.1.js'></script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/gannett-network/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
		<!--[if lte IE 9]>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js"></script>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv-printshiv.min.js"></script>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/respond.js/1.4.2/respond.min.js"></script>
		<![endif]-->
		<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "9289482" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "https://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://b.scorecardresearch.com/p?c1=2&c2=9289482&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

		
	</head>
<!--================================================
==================END: HEADER====================-->

	<body class="__PAGETYPE__">
		
	<div id="fb-root"></div>
	
		<a href="#" id="backToTop"><i class="fa fa-chevron-up"></i></a>
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WF5MZJ9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

		<div id="wrapper-main">
			
					<header id="header-main" class="header header-expanded no-gutter static clearfix">
			<div id="toprail">
	<div class="inner clearfix">
		<a id="button-nav-toggle"
			title="Navigation menu">
			<span class="hidden-sm hidden-xs">Sections</span>
			<i class="fa fa-fw fa-bars"></i>
		</a>
			<ul id="toprail-nav-left" class="list-inline"><li><a href="https://www.yourstephenvilletx.com/news" target="_top">News</a></li><li><a href="https://www.yourstephenvilletx.com/sports" target="_top">Sports</a></li><li><a href="https://www.yourstephenvilletx.com/entertainment" target="_top">Entertainment</a></li><li><a href="https://www.yourstephenvilletx.com/lifestyle" target="_top">Life</a></li><li><a href="https://www.yourstephenvilletx.com/obituaries" target="_top">Obituaries</a></li><li><a href="http://stephenvilleempiretribune.tx.newsmemory.com/" target="_blank">E-Edition</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/txbro" target="_blank">Classifieds</a></li><li><a href="https://www.yourstephenvilletx.com/section/cars" target="_blank">Cars</a></li><li><a href="https://www.yourstephenvilletx.com/jobs" target="_blank">Jobs</a></li><li><a href="https://www.yourstephenvilletx.com/homes" target="_top">Homes</a></li></ul>
		<ul id="toprail-nav-right" class="list-inline">
				<li id="toprail-subscribe"><a href="https://www.yourstephenvilletx.com/subscribenow?g2i_source=yourstephenvilletx.com&g2i_medium=subscribe&g2i_campaign=topRail" target="_top" class="btn btn-sm btn-subscribe hidden-lg">Subscribe</a></li>
			<li id="toprail-search" class="hidden-sm hidden-xs">
											<div id="toprail-search-form">
								<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
									<input class="search-input" name="searchText" placeholder="Search this site" type="search">
									<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
								</form>
							</div>
							<i class="fa fa-fw fa-lg fa-search"></i>
			</li>
				<li id="toprail-login">
					<a class="hide" data-gh-paywall-event="login" href="/login">
						<i class="fa fa-user"></i>
						<span class="hidden-sm hidden-xs">Log in</span>
					</a>
				</li>
				<li id="toprail-weather" class="hidden-xs" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.yourstephenvilletx.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#toprail-weather"></li>
		</ul>
		<div id="toprail-microbar">
			<div class="ad text-center">
				<div class="ad ad-topbanner text-center" data-gh-lazy-ad-bucket-targeting='{"ad-type":"standard","slot":"Base Micro Bar","sov":"base ROS","allow_adx":"false"}' id="topBarSponsor" data-dimensions="[88,31]"></div>
			</div>
		</div>
	</div>
</div>
						<div id="header-main-nameplate">
				<div id="header-main-left">
					<div id="header-main-logo">
						<a href="https://www.yourstephenvilletx.com">
							<img class="mainheadnameplate" src="https://www.yourstephenvilletx.com/Global/images/head/nameplate/yourstephenvilletx_logo.png"  alt="Stephenville Empire-Tribune" />
						</a>
					</div>
				</div>
				<div id="header-main-center">
					<a href="https://www.yourstephenvilletx.com/subscribenow?g2i_source=yourstephenvilletx.com&g2i_medium=subscribe&g2i_campaign=header" target="_top" class="btn btn-subscribe">Subscribe Now</a>
				</div>
				<div id="header-main-right" class="hidden-xs">
					<div id="header-main-promo" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.yourstephenvilletx.com/section/?template=ajaxPromoWiz7" data-gh-fetch-html-dom="#header-main-promo"></div>
				</div>
			</div>
		</header>


<!--==================================================
==========================START: CONTENT===========-->
			<div id="content" class="clearfix">
				

<div class="alert"></div>
<div id="apoc-breaking-wrapper" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.yourstephenvilletx.com/section/breaking_ajax?template=breaking_ajax2" data-gh-fetch-html-dom="#apoc-breaking-wrapper"></div>
<div data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://cdn.gatehousemedia.com/gh-sites/global/breaking/breaking-special.html"></div>

				<div class="ad ad-billboard text-center" id='ad-base-leaderboard-article'>
	<div id="baseLeaderboard" data-size-mapping="baseLeaderBillboardArticle"></div>
	<div data-gh-object-loaded="false" 
		data-gh-object-offset="0" 
		data-secondLevel-7103="leaderboard_atf"
	data-secondLevel-mobile-7103="mobileweb-banner_top" 
			data-gh-object='{"method":"__gh__webApp.utilities.adsRefresh.init","data":{"id":"baseLeaderboard-adRefresh","orgId":"baseLeaderboard","loadNow":"false","container":"ad-base-leaderboard-article"}}'
				class="ad-refresh" 
					data-gh-lazy-ad-bucket-targeting='{"ad-type":"standard","slot":"Base Leaderboard","sov":"base ROS","refresh":"true"}' 
						data-dimensions="[[970,90],[970,250],[728,90]]" 
							id="baseLeaderboard-adRefresh" 
							 data-size-mapping="baseLeaderBillboardArticle" 
								 data-gh-object-parent-height="true"></div>
</div>

				<div id="wrapper" class="clearfix">
					<div id="buckets">
	<article class="full article-v2 loading" data-updated="20201009000036">
	<div class="inner">
		<h1 class="headline">Howe ISD board candidates share thoughts on past, future of district</h1>
		<section class="article-v2-left">&nbsp;</section>
		<section class="article-v2-right">
			        <figure class="thumb">
            <img class="image" src="https://www.yourstephenvilletx.com/storyimage/TX/20201009/NEWS/201009005/AR/0/AR-201009005.jpg&MaxH=200&MaxW=200" width="100%">
            <!--div class="image-caption">
                <div class="description">Clint Catching [Courtesy photo]</div>
                <div class="credit"></div>
            </div-->
        </figure>
			<div class="article-body">
				<span class="byline-item">
					By Joshua Baethge, For the Van Alstyne Leader
				</span>
				<div class="article-meta">
					<div class="inner">
						<div class="article-meta-main">
							<h3 class="article-meta-day">Friday</h3>
							<span class="article-meta-date">Oct&nbsp;9,&nbsp;2020&nbsp;at&nbsp;12:01&nbsp;AM</span>
							<span class="article-meta-updated"></span>
						</div>
					</div>
				</div>
				<br><br>
				<div class="inner">
					<p class="article-summary"></p>
					<p><p>Among many races on the ballot this fall, voters in the Howe Independent School District will get to choose two seats on the board of trustees.</p><br><p>Incumbent Clint Catching will face challengers Jeff Dailey, Charles Haley and Lisa Tibbets. The top two vote-getters in the election will be placed on the board for a three-year term.</p><br><p>Early voting for the Howe ISD race begins Oct. 13 and continues through Oct. 30. Election day is Nov. 3. Grayson County voters can cast their ballots at any polling location in the county. The lone Howe voting location will be the Community Center at 700 W. Haning St.</p><br><p>Clint Catching</p><br><p>Catching has been on the board for six and a half years. During his tenure, the board has overseen the construction of a new school and the completion of several campus improvement projects. The district has remained fully staffed, and enrollment has increased each year until this one, which saw a slight drop attributable to COVID-19.</p><br><p>He says that he wants to continue on the board because he still has kids in the district, so he likes to know what is going on. Catching has had a child in the district since 2000. Two have since graduated. He also has a child who will graduate this year as well as one on pace to finish in 2026.</p><br><p>"The challenge on the board is that we are always dealing with the state funding and making sure that our budgets are balanced," he said. "We have a good business manager in place and a good superintendent, and that really makes the board job much more pleasant."</p><br><p>Catching is a third-generation Howe resident who graduated from the district along with his two brothers and a few cousins. He wants to see the school continue to thrive and maintain a high level of educational success.</p><br><p>"That&rsquo;s always good to see and I&rsquo;d like to think I could be a part of that," he said.</p><br><p>Lisa Tibbets</p><br><p>Tibbets grew up in Howe and is passionate about being involved in her community.  When she heard there was an opening on the school board, she deiced to run because she believes that if you don&rsquo;t get involved, you can&rsquo;t be upset about the way things are.</p><br><p>According to her, the biggest challenge for any school system in Texas is the STAAR test. She&rsquo;s not a fan of it and believes that change starts at the local level.</p><br><p>"We have to let the state know that this is not something that we are interested in for our students," she says. "I also really want more appreciation for our teachers. I think we do a great job in Howe but there can always be more support for teachers."</p><br><p>Having three kids enrolled in the district makes school issues very personal for her. She graduated from Howe High School in 2005 and moved away. Tibbets says she came back because she loves her hometown and wants to see it continue to grow and do better.</p><br><p>Tibbets serves on the Howe Planning & Zoning Commission and is the area director for Texoma Soccer in Van Alstyne and Howe. She also works at Security Titles and is making progress toward her bachelor&rsquo;s degree in psychology and English literature.</p><br><p>"I&rsquo;m a student while I have students so it&rsquo;s kind of a fun thing that we are all in school together," she said.</p><br><p>Jeff Dailey</p><br><p>Dailey has taught in Texas public schools before and believes his experience could be of value to the district.</p><br><p>The two main things he hopes to address are academic performance and planning for growth. He is particularly concerned about how the COVID-19 situation has affected student performance. If elected, he would push for the district to not just meet but exceed expectations.</p><br><p>As for growth, he believes it is something district leaders must address soon as he expects a large influx of new residents in the not-so-distant future.</p><br><p>"You can&rsquo;t change that, and you may not like it, but you have to plan for it," he says. "It&rsquo;s coming and we know it."</p><br><p>Dailey moved to Howe in 2018. Before then, he served multiple terms on the Greenville City Council. He thinks the experience of overseeing a large organization and working with budgets is an advantage for him.</p><br><p>As a practicing attorney, he also believes that his knowledge of the law would help the district in certain situations. He adds that running his own business gives him a good perspective on how to manage money, organize operations and work through complex tasks.</p><br><p>His son is a sixth-grader who has spent his entire school career in Howe. Dailey is also a member of the Army reserves.</p><br><p>Charles Haley</p><br><p>Haley has both a middle school and a high school student attending Howe ISD, which makes him passionate about the district.</p><br><p>"Earlier, when they were younger, I could always serve the community by being a coach or signing up for concessions," he says. "Now that they&rsquo;re older, that time has passed, so when this position came open, I just thought it would be a way to help serve the community."</p><br><p>According to Haley, the biggest challenge the district faces today is overcoming the effects of COVID-19. That includes helping kids catch up academically and assisting the district address what he expects will be a significant financial hit.</p><br><p>"I really care about the next generation of leaders that is coming out of the school system," he says. "This is a real trying time for all of us, students, parents and the community."</p><br><p>Haley and his family are active in sports as well as recreational activities like fishing and hunting. He has worked at Texas Instruments for 25 years.</p></p>
				</div>
			</div>
		</section>
	</div>
</article>
</div>

				</div><!-- /wrapper -->
			</div><!-- /content -->

			<div id="push-main" class="clearfix"></div>
		</div><!-- /wrapper-main -->
<!--==================================================
====================END: CONTENT===================-->
				<footer id="footer-main" class="clearfix">
			<div class="inner container">
				<div id="footer-main-newsletter">
					<div id="footer-main-subscribe">
						<h2>Never miss a story</h2>
						<p>
							Choose the plan that's right for you.<br>
							Digital access or digital and print delivery.
						</p>
						<a href="https://www.yourstephenvilletx.com/subscribenow?g2i_source=yourstephenvilletx.com&g2i_medium=subscribe&g2i_campaign=footer" target="_top" class="btn btn-subscribe">Subscribe Now</a>
					</div>
								<h2>Sign up for daily e-mails</h2>
										<form id="sfNewsletterForm_footer" class="sfNewsletterForm form-inline">
			<input type="email" name="sfUserEmail" class="sfUserEmail" placeholder="Enter Email Address">
			<input type="hidden" name="sfSource" class="sfSource" value="footer">
			<input type="submit" name="sfSignup" class="sfSignup btn btn-newsletter" value="Sign Up Now">
			<div class="sfResults">
			</div>
		</form>
				</div>
				<div id="footer-main-info" data-gh-accordion-loaded="false" data-gh-accordion-panel-dom="#footer-main-info .footer-col ul" data-gh-accordion-toggle-dom="#footer-main-info &gt; .footer-col &gt; h4" data-gh-accordion-open-at="480">	<div class="footer-col"><h4>Site Services<i class="fa fa-angle-down"></i></h4><ul><li><a href="https://supportlocal.usatoday.com" target="_top">Support Local Businesses</a></li><li><a href="http://myprofile.yourstephenvilletx.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=GTCP_SET" target="_top">My Profile</a></li><li><a href="https://www.yourstephenvilletx.com/contact" target="_blank">Contact Us</a></li><li><a href="https://www.yourstephenvilletx.com/submit" target="_blank">Online Forms</a></li><li><a href="http://mediakit.gatehousemedia.com/Stephenville_TX" target="_blank">Advertise With Us</a></li></ul></div><div class="footer-col"><h4>Marketplace<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://www.marketplaceadsonline.com/marketplace/txbro" target="_blank">Classifieds</a></li><li><a href="https://www.yourstephenvilletx.com/section/cars" target="_blank">Cars</a></li><li><a href="https://www.yourstephenvilletx.com/homes" target="_top">Real Estate</a></li><li><a href="https://www.yourstephenvilletx.com/jobs" target="_blank">Jobs</a></li><li><a href="https://www.yourstephenvilletx.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill </a></li></ul></div><div class="footer-col"><h4>Area Publications<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://www.brownwoodtx.com" target="_blank">Brownwood Bulletin</a></li><li><a href="http://www.yourglenrosetx.com" target="_blank">Glen Rose Reporter</a></li><li><a href="http://www.waxahachietx.com" target="_blank">Waxahachie Daily Light</a></li></ul></div><div class="footer-col"><h4>Community Info<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://www.ci.stephenville.tx.us" target="_blank">City of Stephenville</a></li><li><a href="http://co.erath.tx.us" target="_blank">Erath County</a></li><li><a href="http://www.stephenvilletexas.org" target="_blank">Chamber of Commerce</a></li><li><a href="http://www.sville.us" target="_blank">School District</a></li></ul></div>
</div><!-- /footer-main-info -->
			</div><!-- /inner++++/apps/pbcs.dll/article?avis=TX&date=20201009&category=NEWS&lopenr=201009005&Ref=AR -->
			<div id="footer-main-copyright">
					<p id="footer-copyrightInfo">&copy; Gannett Co., Inc. 2020. All rights reserved.</p>
	<p>Original content available for non-commercial use under a Creative Commons license, except where noted.
	<br />Stephenville Empire-Tribune  ~ 702 E. South Loop, Stephenville, TX 76401<span class="gdpr hide"> ~ <a id="ot-sdk-btn" class="ot-sdk-show-settings" href="javascript:void(0);">Do Not Sell My Personal Information</a> ~ <a href="https://www.yourstephenvilletx.com/section/cookie-policy" target="_blank">Cookie Policy</a></span><span class="gdpr-disabled hide"> ~ <a href="https://www.gannett.com/cookie-policy/" target="_blank">Do Not Sell My Personal Information</a></span> ~ <a href="http://www.gannett.com/privacy-statement/" target="_blank">Privacy Policy</a> ~ <a href="http://www.gannett.com/terms-of-use/" target="_blank">Terms Of Service</a> ~ <a href="https://www.gannett.com/ccpa/" target="_blank">Your California Privacy Rights / Privacy Policy</a></p>
	<p><a href="/ownership">Gannett | USA TODAY NETWORK</a></p>
			</div>
		</footer><!-- /footer -->
				<nav id="drawer" role="navigation">
			<a href="https://www.yourstephenvilletx.com/subscribenow?g2i_source=yourstephenvilletx.com&g2i_medium=subscribe&g2i_campaign=drawer" target="_top" class="btn btn-subscribe">Subscribe Now</a><hr>
			<div id="drawer-search" class="hidden-md hidden-lg">
				<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
					<div class="input-group-btn">
						<button type="button"
							class="btn btn-default dropdown-toggle"
							data-toggle="dropdown"
							aria-haspopup="true"
							aria-expanded="false">
							<span class="caret"></span>
						</button>
						<ul class="dropdown-menu" id="searchparam_dd">
							<li data-type="site" class="selected">Site</li>
							<li data-type="archive">Archive</li>
						</ul>
					</div>
					<input class="search-input" name="searchText" placeholder="Search Site" type="search">
					<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
				</form>
			</div>
			<hr class="hidden-md hidden-lg">
			<div class="inner">
				<div id="wrapper-drawer">
						<ul 
					 class="nav" 
					 data-gh-accordion-loaded="false" 
					 data-gh-accordion-panel-dom="#drawer-nav-sections .subnav" 
					 data-gh-accordion-toggle-dom="#drawer-nav-sections &gt; li &gt; a" 
					 id="drawer-nav-sections"
				   ><li><a href="https://www.yourstephenvilletx.com" target="_top">Home</a></li><li><a href="https://www.yourstephenvilletx.com/news"><span class="nav-category">News</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"22041"><a href="https://www.yourstephenvilletx.com/news/community" target="_top">Community</a></li><li id="navLink-TEST-"22042"><a href="https://www.yourstephenvilletx.com/news/education" target="_top">Education</a></li><li id="navLink-TEST-"22043"><a href="https://www.yourstephenvilletx.com/news/state" target="_top">State</a></li><li id="navLink-TEST-"22044"><a href="https://www.yourstephenvilletx.com/news/nation-world" target="_top">Nation/World</a></li><li id="navLink-TEST-"39530"><a href="https://www.yourstephenvilletx.com/news/shareable" target="_top">Shareable</a></li></ul></li><li><a href="https://www.yourstephenvilletx.com/sports"><span class="nav-category">Sports</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"22046"><a href="https://www.yourstephenvilletx.com/sports/high-school" target="_top">High School</a></li><li id="navLink-TEST-"22047"><a href="https://www.yourstephenvilletx.com/sports/college" target="_top">College</a></li></ul></li><li><a href="https://www.yourstephenvilletx.com/lifestyle"><span class="nav-category">Lifestyle</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"52634"><a href="http://www.timeandmoney.com" target="_top">Time and Money</a></li><li id="navLink-TEST-"22049"><a href="https://www.yourstephenvilletx.com/lifestyle/celebrations" target="_top">Celebrations</a></li></ul></li><li><a href="https://www.yourstephenvilletx.com/opinion" target="_top">Opinion</a></li><li><a href="https://www.yourstephenvilletx.com/entertainment"><span class="nav-category">Entertainment</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"39531"><a href="https://www.yourstephenvilletx.com/entertainment/tv-guide" target="_top">TV Guide</a></li><li id="navLink-TEST-"38593"><a href="https://www.yourstephenvilletx.com/calendar" target="_top">Calendar</a></li></ul></li><li><a href="https://www.yourstephenvilletx.com/business-news" target="_top">Business</a></li><li><a href="https://www.yourstephenvilletx.com/obituaries" target="_top">Obituaries</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>More</header><li><a href="https://www.yourstephenvilletx.com/photos" target="_top">Photos</a></li><li><a href="https://www.yourstephenvilletx.com/videos" target="_top">Videos</a></li><li><a href="https://www.yourstephenvilletx.com/calendar" target="_top">Calendar</a></li><li><a href="https://www.yourstephenvilletx.com/submit" target="_top">Submit Your News</a></li><li><a href="https://www.yourstephenvilletx.com/weather" target="_top">Weather</a></li><li><a href="https://www.issuu.com/swdigitalamconmedia.com/docs/cto_november" target="_blank">Central Texas Outdoors</a></li><li><a href="https://www.yourstephenvilletx.com/contests" target="_top">Contests</a></li><li><a href="https://www.yourstephenvilletx.com/ara" target="_top">Branded Content</a></li><li><a href="https://issuu.com/brownwoodbulletin9/docs/set2019_football" target="_blank">Fall Football Guide 2019</a></li><li><a href="https://issuu.com/brownwoodbulletin9/docs/my_baby_set_final0" target="_top">2019 My Baby!</a></li><li><a href="https://issuu.com/brownwoodbulletin9/docs/boe_mag_2019_finall_d906bab7ee1241" target="_top">2019 Best of Erath County</a></li><li><a href="https://www.yourstephenvilletx.com/section/promoted//?prx_adpz=2157" target="_top">From Our Advertisers</a></li><li><a href="https://www.yourstephenvilletx.com/southern-kitchen" target="_top">Southern Kitchen</a></li><li><a href="https://issuu.com/brownwoodbulletin9/docs/_fyipages" target="_blank">2019 FYI</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Subscriber</header><li><a href="http://myprofile.yourstephenvilletx.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=GTCP_SET" target="_top">My Profile</a></li><li><a href="http://stephenvilleempiretribune.tx.newsmemory.com/" target="_blank">E-Edition</a></li><li><a href="https://www.yourstephenvilletx.com/subscribenow" target="_top">Subscribe</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Market Place</header><li><a href="https://local.townsquared.com/businesses/stephenville-tx" target="_top">Business Directory</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/txbro" target="_blank">Classifieds</a></li><li><a href="https://www.yourstephenvilletx.com/section/cars" target="_blank">Cars</a></li><li><a href="https://www.yourstephenvilletx.com/jobs" target="_blank">Jobs</a></li><li><a href="https://www.yourstephenvilletx.com/homes" target="_top">Homes</a></li><li><a href="http://mediakit.gatehousemedia.com/Stephenville_TX" target="_blank">Advertise With Us</a></li><li><a href="https://www.yourstephenvilletx.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill </a></li><li><a href="http://yourstephenvilletx.thrivehive.com/" target="_blank">Digital Marketing Services</a></li></ul>
<footer id="footer-drawer">
	<hr>
	<ul class="drawer-nav-secondary nav">
		<li>
			<a href="mailto:news@empiretribune.com">Feedback</a>
		</li>
		<li>
			<a href="https://www.yourstephenvilletx.com/ownership">Ownership</a>
		</li>
		<li>
			<a href="https://www.gannett.com/terms-of-use/" target="_blank">Terms of Use</a>
		</li>
		<li>
			<a href="https://www.gannett.com/privacy-statement/" target="_blank">Privacy Policy</a>
		</li>
		<li>
			<a href="https://www.gannett.com/brands/" target="_blank">Gannett Publications</a>
		</li>
	</ul>
</footer>
				</div>
				<footer id="footer-drawer">
					<div id="drawer-weather" class="visible-xs-block text-center" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.yourstephenvilletx.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#drawer-weather">
					</div>
					<ul class="social list-inline">
						<li>
							<a	href="http://www.facebook.com/empiretribune""
								target="_blank"
								title="Stephenville Empire-Tribune Facebook">
								<i class="fa fa-fw fa-facebook"></i>
							</a>
						</li>
						<li>
							<a	href="http://www.twitter.com/empiretribune""
								target="_blank"
								title="Stephenville Empire-Tribune Twitter">
								<i class="fa fa-fw fa-twitter"></i>
							</a>
						</li>
						<li>
							<a	href="https://www.yourstephenvilletx.com/section/feed"
								target="_blank"
								title="Stephenville Empire-Tribune RSS Feed">
								<i class="fa fa-fw fa-rss"></i>
							</a>
						</li>
						<li>
							<a	href="https://www.yourstephenvilletx.com/contact"
								title="Contact Stephenville Empire-Tribune">
								<i class="fa fa-fw fa-envelope"></i>
							</a>
						</li>
					</ul>
					<!-- <span id="drawer-copyrightInfo">&copy; 2015 __SITENAME__</span> -->
				</footer>
			</div><!-- /.inner -->
		</nav>
		<div id="drawer-fade-screen"></div>
		<div id="dialog-message" data-gh-object-loaded="false" data-gh-object='{"method":"__gh__webApp.messageCenter.load","data":{"storageKey":"messageCenter"}}' class="slideUp hide">
    <header>
        <h3 class="dialog-title">SUBSCRIBE TODAY</h3>
        <div class="dialog-controls">
            <i id="dialog-minimize" class="fa fa-fw fa-window-minimize"></i>
            <i id="dialog-close" class="fa fa-fw fa-lg fa-times"></i>
        </div>
    </header>
    <div class="inner">
        <div class="dialog-content">
           <p><span>Choose the plan that&rsquo;s right for you. Digital access or digital and print delivery.</span></p>
        </div>
	        <a href="https://yourstephenvilletx.com/subscribenow" class="btn btn-highlight" data-gh-tracker-track-event-object='{"category":"message center pop up","action":"click-action","label":"http://www.yourstephenvilletx.com/apps/pbcs.dll/article?avis=TX&date=20201009&category=NEWS&lopenr=201009005&Ref=AR"}'>
	            Learn More
	        </a>
    </div>
</div>

				<script type="text/javascript">
		__gh__coreData.pageData.pageType2 = "Article";
		</script>
		<script src="//cdn.gatehousemedia.com/gh-sites/global/ads/ads.js" crossorigin="anonymous"></script>
		<script src="//cdn.gatehousemedia.com/assets/2.0.480/app.min.js" crossorigin="anonymous"></script>
		<script>
window.googletag = window.googletag || {};
window.googletag.cmd = window.googletag.cmd || [];
</script>
<script>
  window.confiant = window.confiant || {};
  window.confiant.enable_integrations = ['gpt'];
  var pbjs = pbjs || {};
  pbjs.que = pbjs.que || [];
</script>
<script async="" src="https://confiant-integrations.global.ssl.fastly.net/JYokDAn2beiT-wdiDnha5IuKJm0/gpt_and_prebid/config.js"></script>
<script>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore( A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");</script>
<script async src="https://js-sec.indexww.com/ht/p/183763-221412910371223.js"></script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>
		<script>
		function __gh__init() {
		var delay = 100;
			var maxDelay = 45000;
			var __gh__asyncInit = setInterval(function() {
			    if (typeof $ !== 'undefined' && typeof __gh__webApp !== 'undefined') {
			    	try {
						__gh__webApp.init();
						__gh__webApp.articlePage.init();
					} catch (e) {
						console.error('webapp failed to initialize', e);
					}
			        clearInterval(__gh__asyncInit);
			    } else if (delay > maxDelay) {
			    	console.error('webapp init timed out');
			        clearInterval(__gh__asyncInit);
			    }
			    delay *= 2;
			}, delay);
		}
		</script>
		<script>__gh__init();</script>
			<script async src="//cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.3.5/js/bootstrap.min.js?201604-1" crossorigin="anonymous"></script>

		
<!--currenttimestamp: 2020-10-09&nbsp;12:59:15-->
	</body>
</html>
